Phantom asks me to create a username when I already have one

  • Updated

If Phantom prompts you to create a username when restoring your wallet—even though you already have one—here's why.

Cause

Phantom shows the profile associated with the first wallet you restore (by importing a recovery phrase or signing in with Apple or Google). If that first wallet doesn't have a profile, Phantom prompts you to claim a username.

Any other wallets you restore afterward appear under the newly created profile, even if one of them already has a username.

Solution

Restore the wallet that already has your profile and username first. Then import any additional wallets or accounts. 

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